Jumping Jack Flash weblog

Trovato nuovo sito europeo (Inghilterra) per batterie LiFePO4 e relativa elettronica (BMS, charger)

Posted in auto elettriche, batterie, scooter elettrici by jumpjack on 20 maggio 2014

Si chiama e-greenomotion:

http://e-greenmotion.com/index.php?route=product/product&product_id=68

Ha sia batterie A123 che Hedway (cilindriche), ma in compenso non ha le classiche prismatiche Winston, Sinopoly e Calb.

Però ha gli introvabili BMS da 60V… che poi ho scoperto invece essere effettivamente da 72V, quindi forse è per quello che mi risultavano introvabili! 🙂

Sono gli stessi di EclipseBikes, sempre inglese, ma qui sono personalizzabili, costano qualche euro in meno (92 invece di 98) e vengono spediti gratis!

Ma volendo hanno anche un BMS molto versatile che supporta da 8 a 32 celle in serie! Però ovviamente è caro: 280 euro!

 

 

 

Tagged with: , , ,

Nuovi prodotti per monitoraggio batterie

Posted in auto elettriche, batterie, scooter elettrici by jumpjack on 15 maggio 2014

Tempo fa compilai un elenco di chip utilizzabili (in teoria) per realizzare un monitor/logger per batterie al litio; “in teoria” perché poi in realtà si è rivelato impossibile saldarli con metodi casalinghi perché troppo miniaturizzati.

Uno di questi era il Maxi MAX14921; per esso adesso è uscita una scheda dimostrativa (MAX14921EVKIT#) che permette di testarne la capacità; non sono riuscito a trovare il prezzo, ma immagino che purtroppo si aggirerà sui soliti 100 o 200 euro…

In compenso ho trovato un’Application Note (5760) che spiega come la scheda dimostrativa utilizzi il MAX14921 in configurazione di “ottimizzazione della precisione” con molti componenti esterni ausiliari, ma è possibile anche utilizzarlo da solo (almeno credo), collegandolo unicamente a un microcontrollore tramite un partitore di tensione.

 

http://www.maximintegrated.com/images/appnotes/5760/5760Fig07.gif

 

Il sistema pare sia “molto economico”, ma anche “molto meno preciso”, con errori dell’ordine dei 100 mV, che forse sono un po’ troppi per bilanciare celle LiFePO4, che hanno un range di funzionamento di meno di 800 mV (2800-3600 mV). E tornerebbe comunque il problema dell’ “insaldabilità” dei piedini troppo miuscoli.

Ci sono poi dei prodotti della O2Micro come l’OZ890, con cui qualcuno sembra stia facendo esperimenti:

http://endless-sphere.com/forums/viewtopic.php?f=14&t=48461&hilit=oz890

http://forum.arduino.cc/index.php?topic=156030.0

http://www.pedelecforum.de/forum/index.php?threads/smartbms-oz890-mit-elv-i2c-interface-ansprechen.22492/

Questo sembrerebbe essere un BMS basato sull’Oz890, ad appena 20 euro per 13 celle:

http://www.bmsbattery.com/smart/330-lifepo4lithium-ion-smart-bms-for-513-cells-in-series.html

Il cavo per programmarlo costa 70 euro, ma in quei forum mi pare di capire che hanno trovato un modo per comunicare tramite Arduino.

 

 

 

Diario elettrico Zem Star 45 – 2 maggio 2014: terzo (e ultimo) giro di boa

Posted in auto elettriche, batterie, scooter elettrici by jumpjack on 11 maggio 2014

 

Diario di bordo

dello

scooter elettrico al litio

Zem Star 45

1500W/60Kmh/80Km

 


Clicca qui per l’INDICE DEL DIARIO

INIZIO QUARTO ANNO

 

assicurazioni-2014

Terzo giro di boa, ossia finisce il terzo anno di possesso e utilizzo di questo traballante scooter elettrico cinese, “entrato in servizio” il 2 maggio 2011.

 

Attualmente sono passate circa 6 settimane dall’inizio dell’utilizzo della nuova batteria LiFePO4 da 15 Ah autocostruita (link1, link2, e altri..).

Fino al primo maggio tutto ok, lo scooter è sempre andato come una scheggia, con prestazioni uguali, se non superiori, a quando aveva le batterie nuove.

Poi il 2 maggio, ad assicurazione appena rinnovata… la nuova batteria “ovviamente” si è spenta! 🙂

Si è spenta quando sono arrivato in ufficio, ma da una rapida ricerca-guasti non è stato possibile trovare nessun problema: nessuna puzza di bruciato, nessun filo staccato, nessuno spinotto traballante; per sicurezza ho inserito ben bene gli spinotti, peraltro già inseriti ben bene, del BMS.

Rimessa la batteria nello scooter, mi ha permesso di tornare a casa senza nessun problema.

Boh?

Fatto sta che da allora, da una settimana, la nuova batteria si comporta come si comportava come una di quelle vecchie, spegnendosi ogni tanto senza motivo: posso essere in pianura o in salita, di corsa o piano piano, su strada liscia o disastrata… ogni tanto piglia e si spegne (ma per fortuna viaggio sempre con due batterie in parallelo, quindi non mi si spegne lo scooter in mezzo alla strada).

Oggi ho provato quindi ad adottare il sistema adottato con la vecchia batteria difettosa: ho incollato gli spinotti del BMS con la colla a caldo!

Se non funziona, non so cos’altro inventarmi!

L’unica anomalia che riscontro nella batteria è che la mattina, a fine carica, trovo il BMS un po’ caldo: pensavo fosse normale… senonchè, quando ho aperto la batteria per controllarla, mi sono accorto che la parte di BMS calda non è quella col dissipatore, ma il lato del PCB dove ci sono solo minuscole resistenze e transistor! Non penso che sia un buon segno che scaldi!

Detto questo, anche se non ho ancora scaricato sul PC tutti i grafici di consumo fatti finora, a idea mi pare che la nuova batteria eroghi più energia dell’altra, perchè quella vecchia finisce di ricaricarsi un’ora prima di quella nuova… anche se quella nuova ha un caricabatterie da 4 ampere anzichè 3, ed è da 15Ah anzichè 24! Però devo analizzare i grafici, appena ho tempo…

 

Un altro (nuovo) problema dello scooter è che deve essersi consumato il cavalletto, per cui ora le ruote non restano mai sospese quando metto il cavalletto, per cui lo scooter parcheggiato è un po’ traballante… Però non saprei come risolvere il problema, se non cambiando il cavalletto.

Infine, gli ammortizzatori mi stanno abbandonando: a ogni buca il ballonzolio perdura per qualche secondo più del dovuto.

Non so se vale la pena di cambiarli, prima vorrei provare finalmente a cambiare la ruota davanti, per vedere se riesco così a far rifunzionare il contachilometri, fermo da mesi a 15600 km, e a eliminare il famoso traballio del freno anteriore.

E ci sarebbe anche da comprare un caricabatterie di riserva prima che il 15esimo mi molli

Insomma, alla faccia del risparmio! E per la felicità di tutti i denigratori e detrattori della mia impresa, che gongoleranno e commenteranno non poco, qui e sui forum, leggendo queste righe.

Ma io me ne frego, e continuo a viaggiare elettrico. 🙂

Imperterrito.

Con uno scooter che si regge con lo scotch oggi, con uno scooter elettrico del 2000 l’anno prossimo, e finalmente con una macchina elettrica entro il 2020.

In barba a quelli che, 8 anni fa, mi fecero credere che comprando un’auto diesel avrei risparmiato 1000 euro all’anno rispetto a quella a benzina, perchè il diesel costava meno e l’auto doveva fare 25 km con un litro… invece ne fa 15, e oggi il diesel e la benzina costano praticamente uguale.

Quindi il mio obiettivo ultimo è di non pagare più nè diesel nè benzina, alla faccia loro. Finora infatti ho NON pagato almeno 3000 euro di benzina… di cui1590 di tasse!

Ebbene sì, non ho pagato la mia quota per il disastro del Vajont, l’alluvione di Firenze, la guerra in Abissinia, vari terremoti e crisi finanziarie, più la famosa “tassa sulle tasse”, cioè l’IVA sulle accise.

Anche se alla fine dovessi ripagare questi 3000 euro in ricambi e batterie, sarà comunque un grosso sfizio continuare ad andare dal benzinaio solo per mettere un po’ d’aria nelle ruote! 🙂

 

 

 

Diario elettrico – test nuova batteria

Posted in batterie, scooter elettrici by jumpjack on 31 marzo 2014

Primo test: 20 km (10+10) senza problemi, batteria quasi sempre sopra la seconda di tre tacche, anche in salita.

Secondo test: 34 km: verso il 30 ha iniziato a suonare la riserva; non so se farci affidamento o no, perchè la nuova batteria da 20 celle da 3,2V ha una tensione di carica completa di 72V (3,6V) e una di scarica completa di 40V (2,0V), mentre le batterie originali avevano tensione di carica di 67,2V (16*4,2) e di scarica di 44,8; si tratta quindi di un deltaV di ben 32V (72-40) contro i 22,4 originali (67,2-44,8), e di una tensione di scarica un po’ diversa (4,8 V di differenza). Non so su che tensione sia tarata la riserva.

A fine viaggio la nuova batteria risulta a tensione leggermente più BASSA di quella nuova! (58.5V vs 60.7V). Quindi la cosa sta funzionando al contrario rispetto al progetto iniziale… : non è la batteria nuova a dare supporto a quella vecchia, ma il contrario! 😦  E c’è anche da considerare il fatto che questo BMS non è bidirezionale, quindi la vecchia non può ricaricare la nuova.

Terzo test: 27 km. Quando ha iniziato a suonare la riserva (dopo aver percorso gli ultimi 7 km con l’acceleratore al massimo invece che “normalmente” come ieri), invece di rallentare l’andatura ho deciso di pigiare un po’ sull’acceleratore per vedere se posso considerare l’avviso di riserva un falso allarme o no, cioè se ho comunque corrente anche se la tensione è bassa… ma a quanto pare no: la vecchia batteria si è offesa e si è spenta, e quando ho continuato a “spingere”, si è spenta pure quella vecchia… Questo accade con la batteria vecchia “nera”, che è una di quelle comprate inizialmente con lo scooter; nel prossimo test proverò quella “bianca”, comprata un anno dopo e marcata con un’etichetta per distinguerla.

Al momento di ricaricare, la nuova batteria LiFePO4 era a 58,5 volt, quella vecchia a LiCoO2 a 60,7 V.

Noto un certo sbilanciamento nelle celle:

1: 3.21,  2:  2.98, 3:  2.94,  4: 2.88, 5: 2.93, 6: 3.03, 7: 2.62, 8: 2.94, 9: 3.06, 10: 2.95, 11: 3.05, 12: 2.98, 13: 3.00, 14: 2.98, 15: 2.97, 16: 2.93, 17: 2.99, 18: 3,10, 19: 3.02, 20: 3.05

La cella 1 è quella che ho sostituito, ma non ho annotato le singole tensioni a inizio carica.

Scrivo qui questi dati solo come promemoria per me “sul cloud” e per i posteri, non c’è bisogno di commentare se non c’è niente da dire…

Le celle sono Headway 40152 da 15 Ah, quindi l’autonomia stimata della singola nuova batteria sarebbe di 15 km scaricandola all’80%, 20 scaricandola al 100%. La vecchia batteria sarebbe da 24Ah ma è ormai esausta e da sola non è più in grado di spingere lo scooter nemmeno appena caricata. Ho quindi un totale di 39 Ah e quindi un’autonomia teorica di 40 km se le batterie fossero entrambe nuove; la vecchia LiCoO2 da 24 Ah, da nuova, aveva un’autonomia do 38  km scaricata al 100%!

 

Diario elettrico zem star 45 – 20 marzo 2014: Costruzione nuova batteria – primi test

Posted in Uncategorized by jumpjack on 20 marzo 2014

image

Purtroppo non è venuta proprio come speravo….
La causa maggiore della schifosità è il BMS, che ho dovuto mettere esterno per via dei morsetti troppo sporgenti.
Comunque sia, la batteria è terminata, e ho iniziato i primi test:
1) ricarica: connesso il CB al connettore di ricarica, la ricarica parte senza problemi
2) prova al banco: dal connettore di potenza escono 67,7 volt
3) accensione scooter: il motore gira
4) movimento scooter in pianura: ottima ripresa, come da nuovo, nessun suono della riserva, nemmeno usando la batteria da sola
5) movimento in salita: nessun problema, buona ripresa come con batterie nuove; usata però la batteria in parallelo a una vecchia originale, per non sforzarla inutilmente

Resta ora il test più difficile: la longevità. La precedente versione della batteria si è rotta per via delle vibrazioni stradali; questa l’ho riprogettata da zero per evitare questo tipo di problema, ma c’è stato l’imprevisto del BMS forzatamente esterno, che mette a rischio-sfregamento alcuni fili. Ho però trovato una soluzione:

image

Nella foto si vede in realtà una soluzione e un problema: a sinistra, il capocorda piegato a 90° potrebbe risolvere il problema dell’ingombro; a destra, invece, si vede che il morsetto di ricarica si è strappato durante il viaggio di prova… sebbene il connettore non fosse collegato a niente! Le vibrazioni stradali sono possenti a Roma! Comunque è un guasto da poco.

A breve la messa a punto con BMS interno.

Diario elettrico zem star 45 – 18 marzo 2014: Progressi costruzione nuova batteria – v.2.0

Posted in Uncategorized by jumpjack on 18 marzo 2014

La batteria è terminata elettricamente, ma non meccanicamente: col nuovo layout è molto più semplice costruirla e fare, se serve, manutenzione, ma le dimensioni ristrette della scatola-batteria originale la rendono pericolosa come batteria di trazione:se fosse statica non ci sarebbero problemi, ma le vibrazioni potrebbero facilmente far toccare i due sotto-pacchi di celle, distanti tra 3 e 5 mm! Dovrò quindi aggiungere un bel separatore spesso 1 o 2 cm, anche se per farlo dovrò eliminare uno dei 6 lati della scatola e far sporgere le celle di 1 o 2 cm (ma tanto ci sono i 5 cm di margine guadagnati eliminando la maniglia di plastica e sostituendola con una di stoffa).
Progressi:

image

image

image

image

Tagged with: , , ,

Diario elettrico Zem Star 45 + Oxygen Lepton: le batterie dello Zem sul Lepton

Posted in auto elettriche, batterie, scooter elettrici by jumpjack on 16 luglio 2013

Scoperta importantissima oggi per il mio Lepton!

Può funzionare anche con le batterie da 60V dello Zem!

Ovviamente è la prima prova che avevo fatto mesi fa… ma non aveva funzionato, solo che siccome lo scooter non funzionava più nemmeno con le SUE batterie al piombo, pensavo fosse colpa dello scooter….

Poi però oggi, dopo aver visto più volte che lo scooter funziona, sia col piombo che col LiFePO4, e soprattutto dopo aver letto sul manuale che la centralina prevede un codice di errore se la tensione della batteria supera i 70 (settanta) volt, ho deciso di rifare la prova.

Non ha funzionato nemmeno questa volta!

Allora riattacco le celle thundersky… e funziona.

Misuro le batterie dello Zem: 60 e 64 volt.

Ma allora?!?

Fammi un po’ esaminare la cosa da vicino…

Questo è il coccodrillo che ho inserito nel connettore Anderson…

cocco2

questo è il connettore Anderson…

spina2

e questi sono tutti e due insieme:

spina+cocco

Il coccodrillo entra esattamente nel buco dell’Anderson, quindi è praticamente perfetto… senonchè… osservate bene la prima immagine!

cocco3

Il morsetto è sostanzialmente bucato! Fa contatto solo sugli angoletti indicati dalle frecce rosse… che cadono ESATTAMENTE sul binario IN PLASTICA dell’Anderson!!! Quindi non avevo collegato proprio niente!!!

Una volta messi i morsetti di shghimbescio in modo che l’ancolo toccasse i contatti, il Lepton è partito senza problemi!

(notare che i contatti in metallo dell’Anderson della foto li ho alzati io cercando di fargli fare contatto, ma normalmente finiscono sotto la plastica).

———

Altra cosa molto importante è che una batteria dello Zem è larga quanto il copri-batterie del Lepton, e ben più stretta della pedana:

vano2

Il blocco nero in alto è il trolley-batteria; il disastro di fili in basso è il mio concetto di batteria autocostruita 🙂 In basso sui due lati si intravede il solco che ospita il copri-batteria, poco più largo delle batterie.

La batteria dello Zem non potrà mai entrare nel vano… intera, ma essendo composta di due blocchi di celle larghi la metà della valigetta, basterebbe tirarli fuori e disporli impilati anzichè affiancati nel vano, oppure affiancandoli attaccati e spostando sopra il BMS, che ora sta invece tra i due blocchi

Ovviamente però non avrebbe senso mettere queste pessime batterie nel Lepton, ma la notizia importante è un’altra: le nuove batterie dei nuovi Zem, ora EcoItalMotor, non sono più li-ion ma LiFePO4, all’incirca dello stesso amperaggio.

Solo che non usano celle cilindriche ma a sacchetto (così mi hanno detto, non le ho viste), quindi non so se potrei diassemblarle come descritto e ficcarle nel vano del Lepton… Di qui l’importanza che possano comunque stare sulla pedana senza dare fastidio: adesso che ho la colonnina di ricarica in cortile, dovrei solo fissare stabilmente alla pedana e riparare dall’acqua due batterie a valigetta per rivitalizzare il Lepton.

Perchè tutto questo sbattimento???

Semplice: perchè tutto questo vuol dire che potrei comprare due nuove batterie LiFePO4 per lo Zem, usarlo finchè non scade l’assicurazione l’anno prossimo a maggio, dopodichè spostare le batterie sul Lepton.

Solo che le nuove batterie costano 800 euro l’una invece che 500… quindi probabilmente ne comprerò una sola, alla quale affiancherò quella ancora sopravvisutta a li-ion, naturalmente separando le due chimiche con un bel paio di diodi. E potrei anche usare lo scooter “rianimato” dalla nuova batteria per andare al Centreo Assistenza EcoItalMotor di via Voghera per vedere se si può sistemare il traballìo della ruota anteriore.

Certo, ricaricare questo miscuglio di batterie potrebbe diventare un bel casino, se non trovo un modo valido di montare DUE caricabatterie sullo scooter in modo che siano a prova di pioggia; paradossalmente, la cosa più complicata sarebbe la ricarica, non il collegamento o l’installazione.

Ma tanto per pensarci su avrei quasi un anno.

Batteria boost a123 – primi test

Posted in batterie, scooter elettrici by jumpjack on 24 maggio 2013

Finalmente è l’ora del test su strada!

Accroccato lo scrondo sul porta-bauletto, faccio i vari collegamenti e mi accingo a partire… ma qualcosa non va.

Primo test:

Batteria Lepton a 49.2 V

Batteria boost a 52.6

Collego “B-” alla massa dello scooter, “B16/B+” al positivo dello scooter (ma con le batterie al piombo staccate), accendo lo scooter, accelero… la ruota inizia a girare. OK, sembra funzionare.

Però, appena provo ad accelerare… inizio a sentire puzza di bruciato! Il BMS fuma!!! Porco cane, stacco tutto!!!

Ma che è successo?!? Ricontrollo i collegamenti… aspetta un po’, mi sa che non devo collegare B- alla massa dello scooter, ma P- (Power, cioè l’uscita del BMS). Non capisco come collegare B- (ingresso al BMS, proveniente dalla batteria al litio) al negativo della batteria al piombo col positivo scollegato possa aver bruciato qualcosa, boh?!? CH- invece (ingresso di ricarica del BMS) neanche l’ho usato, perchè l’unico modo sarebbe collegarlo alla massa dello scooter, visto che dovrebbe essere la batteria dello scooter a ricaricare la batteria boost, quindi nel dubbio per ora l’avevo lasciato scollegato.

Secondo test:

Visto che, dopo la fumata, tra P- e P+  ci sono comunque ancora 52 volt, faccio il collegamento “giusto” (?), cioè P- alla massa dello scooter e P+ al positivo, e provo a ripartire: lo scooter fa cinque centimetri e poi si spegne tutto con un’altra fumata del BMS seguita da un piccolo scoppietto! E stavolta tra P- e P+ compaiono due soli volt… Mi sono giocato il BMS! (a vedersi sembra scoppiata una resistenza, ma boh…)

Terzo test:

va bene, il BMS è andato, ma una prova devo riuscire a farla lo stesso, tanto una sola “scaricata” alle batterie senza bilanciamento non può danneggiarle, e visto che sopportano 60A continui e 120 per 10 secondi, non dovrebbero esserci problemi a fare un po’ di brevi prove. Quindi bypasso il BMS, e collego al negativo dello scooter non P- ma B-; così mi accorgo che il B- della batteria al litio NON era collegato al B- del BMS, ma rimasto volante…. ???? Possibile allora che questo abbia fatto bruciare il BMS? Continuo a non capire.

Comunque, almeno adesso, con le batterie connesse direttamente, lo scooter funziona: riesco a partire, a fare una decina di metri, poi comincia la salità del 15-20%: riesco a salire… ma stranamente vado PIU’ PIANO che con le batterie al piombo (al momento ancora scollegate). Ma come?!? E ‘sti 60/120A dove cavolo sono?!? Per di più, non riesco nemmeno ad arrivare in cima alla salita (lunga forse 100 metri), lo scooter si ferma! Devo attaccare le batterie al piombo per arrivare in cima e poter continuare i test!

Quarto test:

Adesso collego sia le batterie al piombo che la boost al litio, e faccio diverse volte il salitone; ogni volta, quando arrivo in cima, i cavi “leggeri” della batteria al piombo non sono caldi: SCOTTANO! Se la salita durasse un minuto invece che 20 secondi, probabilmente la guaina si scioglierebbe, o peggio si incendierebbe!!! Nessun problema invece sui cavi originali, al massimo sono tiepidi quelli più sottili.

Problemi (previsti) invece, sulla batteria al litio: per bypassare la cella che non sono riuscito a saldare, in mancanza di cavo adatto avevo dovuto usarne uno più sottile degli altri, e quindi è diventato tiepido, ma comunque molto meno caldo di quello delle batterie al piombo. Ma come MENO? Non doveva venire per lo più dalla batteria boost la corrente?!?

Ma non è tutto: dopo mezz’ora di prove, non sono solo i fili a essere caldi: tutte le celle sono molto calde! Non scottano, ma sono palesemente calde, e questo non va bene per niente: si sono scaldate dopo tre salite?!? E dopo un’ora di viaggio in scooter cosa farebbero, si squaglierebbero?!?

Al termine dei test, la batteria boost dà 46.6 volt, cioè in teoria 2,91V a cella…. ma stupidamente ho dimenticato di misurare le singole celle per sapere se il BMS, a parte non avere più il circuito di potenza, riesce almeno a bilanciare! Me ne ricordo solo 3 ore dopo: quasi tutte le celle sono tra 2,91 e 2,94V, tranne 2 che sono una a 3,00 e una 2,50. Ma quel che è peggio è che la cella n.1 è a 0,10V (zero virgola 10???). Come fa una cella al litio ad arrivare a 0,10V?!? Senza scoppiare o incendiarsi, per giunta?!?

Non ci siamo proprio, questi primi test sono davvero deludenti e preoccupanti!

Però anche il mio accrocco è deludente, con saldature approssimative, cavi inadatti, e BMS fritto.

Ho ordinato una speciale pasta per saldare l’alluminio, per cercare di saldare l’ultima cella: quando arriva, se funziona risaldo per bene tutte le celle, e potrò fare i test col BMS da 60V, e vedere un po’ cosa succede.

Intanto, per adesso ho imparato questo sui BMS:

  • P-/P+: contatti di Potenza in uscita dal BMS; ma in realtà P+ non c’è sul BMS, è il polo positivo della batteria a fungere da P+ (oltr eche da B+, vedi sotto).
  • B-/B+: contatti di ingresso al BMS, provenienti dalla batteria; ma in realtà B+ non esiste, perchè B+ e P+ vanno insieme.
  • CH-/CH+: contatti di ricarica della batteria; anche qui, il positivo non esiste sul BMS, perchè è in comune con B+ e P+. In pratica, CH+, B+ e P+ sono tutti la stessa cosa, e cioè il polo positivo della batteria, ossia dell’ultima cella, quindi il contatto B16 della serie. Invece, B- sarebbe il contatto Bzero, cioè il negativo della prima cella, mentre B1 è il positivo della prima cella.

Non mi è ben chiaro se e come posso usare CH- nella mia configurazione con batteria che deve sia scaricarsi sullo scooter che ricaricarsi tramite lo scooter, anzichè ricaricarsi tramite caricabatterie esterno.

La cosa bizzarra è che nel BMS da 48V il B- non è presente tra i fili di bilanciamento, quindi il negativo della batteria va collegato al BMS separatamente, mentre in quello da 60V il B- è il primo contatto del morsetto.

Gli schemi di cablaggio dei due BMS:

48VBMS60A-150A

60VBMSAGGIORNAMENTO:

QUeso è come credevo che dovesse essere un circuito con batteria boost:

Diapositiva1

Questo è quello che pensavo dopo aver letto gli schermi di cablaggio dei miei BMS:

Diapositiva2

Questo è invece quello che penso dovrebbe essere in realtà, dopo una lettura più approfondita:

Diapositiva3

Evidentemente il controllo sulla corrente erogata viene effettuato sul “canale negativo” del collegamento, visto che sul BMS non c’è nessun morsetto positivo.

Per quanto riguarda il morsetto CH- di ricarica… boh? 🙂 Che ci faccio? Se lo collego al “-” della batteria al piombo, vuol dire che lo metto in corto con P-, non lo so mica se si può fare!!

Detto questo, ecco i “veri nomi” dei due BMS, scritti sui PCB, molto ben nascosti nel “sandwich” (sono 3 PCB sovrapposti per ogni ):

60V: PCM-L24S60-622(A)

48V: PCM-L16S70-563(B)

Tagged with: , , , ,

Batteria boost a123 – Lo scrondo2 – ci siamo quasi

Posted in Uncategorized by jumpjack on 23 maggio 2013

image

Ieri era solo un ammasso di celle al litio, oggi ho aggiunto l’agglomerato di cablaggi che fa delle celle una batteria: un connnettore da 13 piu’ + uno da 8 per la batteria da 20 celle / 60V, due connettori da 8 per la batteria da 16 celle / 48/. Purtroppo al momento non posso connettere il BMS da 60V perche’ non sono riuscito a saldare un’ultima cella, ma il BMS da 48V e’ collegato, e la batteria da 48V pronta per i primi test sul Lepton. Una prima verifica sara’ vedere se i fili della batteria al piombo che la volta scorsa si sono surriscaldati si surriscaldano ancora: se l’ENEA dice il vero e se una cella da 60A puo’ fare davvero le veci di un supercondensatore, non si surriscalderanno. Vedremo.

Tagged with: , , ,

Diario elettrico Zem Star 45: autocostruzione batteria boost LiFePO4 A123

Posted in batterie, scooter elettrici, Uncategorized by jumpjack on 15 maggio 2013

Ho scoperto che le celle che ho acquistato sono in qualche modo “difettate”: le ho infatti richieste espressamente dotate di linguette pre-saldate, avendo letto che è piuttosto difficile saldarle a mano a causa della sensibilità delle celle al calore ed essendo complicato saldare a mano le particolari linguette “spaccate”; le linguette sono infatti dotate di un taglio che permette di saldarle senza coprire le valvoline di emergenza situate agli estremi delle celle (in teoria solo su un lato, ma a guardar bene sembra che ci siano su entrambi, anche se su un lato è di plastica e sull’ altro di metallo).

Questa figura mostra una cellapiù piccola di quelle che ho preso io, è una 18650 mentre io ho preso le 26650, ma la linguetta è più o meno simile almeno come spessore, a quelle delle mie celle, e anche per il fatto dell’assenza dello spacco/foro centrale:

a1239u

Questa invece è una cella con le linguette  giuste:

a123-okOltre ad avere lo spacco al centro, hanno anche dei comodi fori utilizzabili per avvitare, piuttosto che saldare, le celle le une alle altre.

In quest’altra figura si vede meglio come deve essere fatta una linguetta:

linguetta

Qui invece si vede una cella come le mie, e al centro dell’estremità sinistra si vede la valvolina di sfogo in plastica; dalla parte opposta c’è un “cerchietto” simile, ma metallico.

a123-26650

 

Qui si vedono i due lati opposti di una cella; mi chiedo come 4 puntini di saldatura da mezzo millimetro quadro possano condurre 60 Ampere… Forse servono solo come “appuntatura” per rendere più facile la saldatura, e le linguette vanno comunque saldate?

duebatt

 

Scopo di queste valvoline è far sì che in caso di guasto alle celle (cortocircuito, sovrascarica o che so io), i gas che si dovessero produrre all’interno romperebbero la valvolina e potrebbero uscire liberamente. La cella risulterebbe comunque irrimediabilmente danneggiata e inutilizzabile, ma con un grosso vantaggio: non esploderebbe! Cosa che invece potrebbe succedere se la valvolina di sfiato fosse ostruita!

Non solo:

ho misurato col calibro lo spessore delle linguette, che risulta essere di 0,3 mm; poichè le linguette sono larghe 1 cm (10 mm), risulta che l’area della sezione trasversale è di 3 mm^2; ora, queste celle sono date come capaci di scaricare continuativamente 60-70 Ampere,  e fino a 120 Ampere per 10 secondi; considerando la regoletta “4A ogni mm^2” da usare per determinare lo spessore di un filo in base alla corrente che deve tollerare, risulterebbe che i fili che collegano una cella all’altra in serie dovrebbero avere diametro di 60/4 = 15mm^2 come minimo, ma 30 mm^2 per tollerare la corrente massima.

Abbiamo quindi 3 mm^2 invece di 15 o 30, o, vista al contrario, linguette in grado di tollerare al massimo 12A.

Anche se potrebbe andare bene per i miei scopi, dovendo la batteria-boost solo supportare le normali batterie di bordo, che erogano insieme intorno ai 25A (60V per 1500W), non mi sembra tecnicamente sensato correre il rischio; ho letto che le linguette possono essere staccate, quindi ho fatto un po’ di prove:

– con un dremel (trapano ad alta velocità da modellismo) ho “grattato” via i mini-punti di saldatura, per poi tirare via la linguetta; risultato: mi sono affettato un dito (quelle linguette sono affilate come rasoi!!!), ma la linguetta è venuta via, anche se lasciando qualche residuo metallico sulla cella.

– ho provato a strappare via la linguetta senza usare il dremel, semplicemente “arrotolandola” intorno a una pinza dalla punta sottile: si stacca molto meglio, rimangono molti meno residui, che poi comunque posso limare via col dremel, ottenendo una superficie completamente liscia, su cui le lnuove linguette potranno aderire facilmente.

Adesso le celle sono tutte ripulite e in attesa delle linguette adatte: le ho ordinate su flymodelcomponents.it:
http://www.flymodelcomponents.it/shop/product.php?productid=17225&cat=0&page=1

barrette-A123

Devo affrettarmi perchè ormai le batterie dello scooter mi stanno definitivamente mollando, al punto che non so nemmeno più se le batterie boost saranno sufficienti!

Se magari fanno davvero le consegne in 24/48 ore, potrei avere il materiale in tempo per lavorarci nel weekend.