Jumping Jack Flash weblog

Diario elettrico GreenGo icaro – 3 agosto 2018 – Modifiche elettriche

Posted in Diario elettrico GreenGo Icaro by jumpjack on 4 agosto 2018

Oggi ho avuto modo di esaminare l’elettronica del cruscotto, per l’esattezza i vari collegamenti dietro alla pulsantiera del cambio.

Controllo volume

L’obiettivo era verificare la fattibilità di separare il controllo del volume dal controllo delle marce, visto che è inverosimile rischiare di mettere in folle per sbaglio mentre si alza il volume della radio.

Risposta breve: sì, è fattibile.

Inizialmente sembrava una cosa complicatissima, perchè questo è quello che c’è dietro a quei 3 pulsanti:

encoder (1)

Non capisco il perchè di tutta questa circuiteria, comunque quello che conta è il gruppetto di 6 pin a destra: è completamente indipendente dal resto del circuito, e fa capo all’encoder con interruttore, cioè la manopola che si usa per accendere la radio e cambiare il volume; quindi bastano 6 fili per spostare il “pericoloso” volume in un posto più sicuro: per esempio, al posto della terza manopola, accanto alle due di areazione e riscaldamento, che di serie nella Icaro A1 è inutilizzata.

Ora devo cercare di capire se quell’ “affare” è effettivamente un “encoder”, e come si usa.

Possibile che sia questo?

71to2bx8xkzl-_sl1200_

Se è lui, come identifico i pin CLK, DT e SW su quello della Icaro? Avranno posizionamento standard?

 

 

L’antenna

Continuando l’esame dei fili, ho  fatto un’altra scoperta:

Queste erano le drammatiche condizioni del connettore dell’antenna della radio! Ecco spiegato perchè prendeva tre stazioni e pure male! Il collegamento tra calza del cavo e involucro del connettore è completamente tranciato! Guida d’onda aperta, onde radio che se ne vanno a spasso invece di entrare nella radio!

Ma quello che è più strano è che, a vederlo, questo connettore era fatto male pure quando era sano, con solo una misera linguetta a unire la calza al connettore: rotta  o non rotta, interrompe la guida d’onda, e l’antenna diventa completamente inutile!

Il venditore mi ha regalato un’antenna esterna come questa. Notare la profonda differenza del connettore, che è un tutt’uno col cavo!

Adesso la radio prende stazioni che nemmeno sapevo esistessero! 🙂 ne prende una ogni 0.10 MHz

E sono anche riuscito a trovare un punto dove fissare l’antenna… talmente perfetto che probabilmente è fatto apposta: sui montanti anteriori, alla congiunzione col cofano, ci sono due coperchietti di plastica, fermati da una vite nascosta sotto al cofano; bè, la vite stessa può essere usate per fissare l’antenna, togliendo la vite con cui essa viene fornita; il filo si fa passare sotto al coperchietto di plastica (da cui bisogna però segare via una piccola tacca per non incidere il cavo, ed è fatta:

 

Connettore misterioso

Ma l’esame dell’impianto elettrico continua: rimontando i connettori, che sono tutti diversi e quindi non c’è rischio vengono scambiati… mi sono accorto che invece due sono identici! Doh! Però per  fortuna sopra c’è una targetta: “Gear” è il cambio; e “Mode switch” a che diavolo serve?? Un connettore “segreto” di servizio per accedere alla configurazione della macchina.

Può darsi… ma collegarlo non è stato sufficiente, e premere a vanvera i tasti del cambio nemmeno: ci sarà sicuramente anche una combinazione segreta dei tasti…. Infami!

 

SD card con mappe

Ultima scoperta: la SD Card nel navigatore.

Sostituire il navigatore semi-funzionante con uno funzionante era l’obiettivo principale di tutto lo smontaggio… ma non ho potuto portarlo a termine perchè ANCHE questo navigatore ha connessioni diverse! ALCUNE sono uguali, ma non tutte… quindi nisba, non ho potuto collegarlo.

PERO’ per puro caso sono riuscito a scovare la microSD card di cui a volte il navigatore lamenta la mancanza o malfunzionamento, nascosta DIETRO al navigatore, sul bordo, quasi invisibile; mentre invece in quello nuovo che mi hanno dato non c’è. Mah? Comunque ho approfittato per fare un backup delle mappe, non si sa mai.

 

 

Bocchette di areazione

Un’ultima osservazione non riguarda l’impianto elettrico ma le bocchette di areazione… che diventeranno parte dell’impianto elettrico quando ci metterò dentro delle ventole aggiuntive; beh’, ho scoperto che la griglia di cui sono dotate posteriormente non solo è flessibile abbastanza da poter alloggiare anche potenti ventole spesse 20mm (che arrivano a 50 m3/h invece dei 9 di quelle da 10mm che ho comprato…), ma secondo me la griglia può tranquillamente essere rimossa senza danneggiare esteriormente le bocchette; anzi, non capisco proprio cosa ci stia a fare… come non capisco cosa ci stavano a fare i riduttori di flusso dietro alle bocchette. Boh, misterio dell’areazione-logia, io tolgo tutto e ci piazzo 4 ventole. 🙂

 

Diario elettrico GreenGo Icaro: primo guasto!!!

Posted in Diario elettrico GreenGo Icaro, minicar elettriche by jumpjack on 12 marzo 2018

Da non credere, ma dopo pochi giorni di vita, eccomi già al primo guasto! Ed un guasto ELETTRICO!

Per farla breve

Stamattina l’auto non si muoveva. Quadro regolarmente acceso, scritta READY, pulsante rosso alzato, pompa servofreno funzionante, tutti i servizi ok… ma l’auto non si muoveva di un millimetro!

I dettagli

Dovendo andare a lavoro, stamattina non ho potuto fare molto di più che controllare se i morsetti erano tutti serrati…. poi sono andato a lavoro a petrolio…

Tornato a casa, ho chiamato l’assistenza chiedendo lumi; il venditore ha detto che lui non ne sa niente, l’auto ha sempre funzionato. Il concessionario da cui l’ha presa lui mi ha dato qualche suggerimento: pare che sia un problema noto la difficoltà ad avviare le icaro col freddo, o a batteria di servizio non proprio carica, perchè non riesce ad alimentare “qualcosa”; il problema è che per ricaricarsi, deve essa stessa attivare il relè che le fa arrivare corrente dal DC/DC… in un assurdo circolo vizioso che impedisce l’avvio! Dice che conviene tenere in macchina uno “starter” per auto a benzina!!!

Pare però che qualcuno abbia fatto una certa modifica per risolvere questo problema… ma comunque non era il MIO problema: osservando la centralina, infatti, mi sono accorto che i LED rosso e verde erano spenti! No power! Il concessionario mi ha detto di provare a “resettare” staccando il fusibile da 40A che viene dalla batteria di alimentazione; l’ho fatto, ma non è servito.

Allora ho cominciato a smanettare un po’ cavi cavetti e morsetti e… ATTENZIONE! UN LAMPEGGIO! Toccando un cavo, si è acceso per un attimo il LED rosso sulla centralina! Ritoccandolo e tenendolo in posizione, il led rosso si è spento e si è acceso quello verde: centralina pronta! Ma appena ho tolto la mano dal cavo… PUF! Tutto spento!

Però ho ristretto l’area di ricerca del problema: il connettore a 9 pin che unisce motore e centralina.

Il connettore

Ecco come appariva il connettore, lato motore:

Sembra normale… ma manca una cosa fondamentale: il blocca-pin!

Senza questo pezzo, i pin inseriti da dietro sono liberi di tornare indietro quando si inserisce il maschio da davanti! …ed è proprio quello che è successo esattamente al pin 1, proprio quello di alimentazione della centralina! Arretrato talmente tanto da non essere più nemmeno visibile da davanti; l’ho spinto un po’ a mano e l’ho rimesso in pari, come si vede nella prima foto. Dopodichè ho montato il blocca-pin,  che di fatto impedisce alle linguette blocca-pin di alzarsi e sbloccare i pin; a sua volta il blocca-pin è bloccato da un’altra linguetta, insomma un complicato sistema di sicureza per un connettore dalla connessione ultrasicura… se ci metti tutti i pezzi!

Ora, un’assurda coincidenza astrale ha voluto che due anni fa io acquistassi una centralina Kelly per il mio scooter elettrico Ecojumbo, che viene fornita coi fili volanti, senza connettori; quindi comprai anche due connettori, uno a 6 e uno a 9 pin; ebbene… proprio QUESTI connettori, identici! Quindi ho potuto cannibalizzare la griglietta gialla dal mio Ecojumbo e montarla nel connettore della Icaro!

Ecco il connettore correttamente assemblato:

Sezione del connettore, per evidenziare il funzionamento del sistema di blocco dei pin:

Adesso tutto è tornato a funzionare perfettamente.

Fino al prossimo guasto. 🙂  …che potrei anche causare io, appena inizierò a riprogrammare la centralina…

Domanda: possibile si siano dimenticati di montare questo pezzo? Possibile sia caduto a me quando ho aperto il connettore ieri per esaminarlo e verificare come collegare la centralina per riprogrammarla? Per terra non ho trovato niente, e comunque non è che la griglietta si sfila e via: per toglierla dall’Ecojumbo ho dovuto fare leva con un cacciavite! Probabilmente mancava già, ma nell’aprire il connettore ho ovviamente tirato leggermente i fili dei pin; non sarebbe successo niente se ci  fosse stata la griglietta… ma non essendo presente, “mi è venuto dietro” il pin 1!

Mah.

Comunque, l’importante è che adesso tutto funzioni.