Jumping Jack Flash weblog

Trovato BMS personalizzabile non cinese

Posted in auto elettriche, hardware, scooter elettrici by jumpjack on 28 novembre 2016

Per una volta ecco un BMS che non sia fabbricato e venduto in Cina:

 

product_template_16-jpeg

Energus Tiny BMS s516

Ha diverse grosse particolarità:

  • ha firmware aggiornabile
  • supporta un numero a piacere di celle tra 5 e 16, con qualunque chimica
  • ha la connessione bluetooth
  • effettua il log delle celle
  • esiste in varianti da 30, 150 e 750 Ampere

 

I prezzi partono da 135 euro, con spedizione dall’Europa.

 

 

 

Diario elettrico Ecojumbo 5000 – batteria riparata

Posted in batterie by jumpjack on 13 novembre 2016
I pezzi sono arrivati, ho fatto tutti i collegamenti bms/celle, e la batteria funziona.
Tutto ok… però… in realtà non tutti i pezzi vanno bene:
– avrei dovuto prendere un connettore da 13 anzichè da 12: avevo dimenticato che sul mio i sono 21 pin, non 20! (alcuni ne hanno solo 20…) Ho rimediato facendo un collegamento volante alla massa… ma non mi piace per niente!
– i pin femmina che ho preso non vanno bene; nelle immagini su RS è quasi impossibile capirlo, ma ora che ho in mano spinotto e pin, mi sono reso conto che un certo tipo di pin va solo su certi tipi di spina, altrimenti non si incastra a scatto, quindi si sfila facilmente! Solo che per capirlo bisogna guardare i pin con la lente di ingrandimento, o avere a disposizione foto dello spinotto e del pin fatte dal lato dell’incastro, mentre su RS le foto sono del tutto a caso!
Adesso però ho capito anche  come scegliere l’accoppiata spina/pin su RS a prescindere dalle immagini; per esempio, scegliendo uno spinotto “JST serie ZH”, quando vado a scegliere il pin femmina dovrò specificare come filtro,  nel campo “per utilizzo con”, la serie giusta, cioè ZH.
Quindi, se per esempio scelgo lo spinotto 762-0866 (codice costruttore ZHR-13), dovrò associargli i pin 762-0761  (codice costruttore BZH-003T-P0.5), fatti così:
pin-femmina-jst-zh
lo spinotto corrispondente a 13 vie:
spina-jst-femmina
Quest’immagine mostra la difficoltà nello scegliere il pin giusto:
spina-pin
– la stripboard che ho usato è troppo piccola; pensavo di poterla accroccare un po’ mettendo insieme due ritagli; in effetti la cosa ha funzionato… ma il lavoro non mi sembra abbastanza solido e pulito per resistere alle vibrazioni stradali per anni; quindi ho deciso di comprare una nuova stripboard bella grande, da poter sagomare senza compromessi, secondo le mie specifiche esigenze.
Ho usato una stripboard perchè il circuito è il seguente:
20161109_175909.jpg
I cavi in basso vengono dal BMS, quelli in alto dalla batteria; in mezzo c’è un’altra fila di spinotti per un’altra batteria, e 3 pinstrip dove attaccare temporaneamente un CellLog8S per monitorare le celle; avendo il CellLog solo 9 pin per monitorare 8 celle, per poter monitorare l’ultima cella del primo gruppo ho dovuto mettere una strip a 10 pin invece che 9, e collegare l’ultimo pin al gruppo successivo, così basta “shiftare” il cellog di una posizione per monitorare le celle da 2 a 9, mentre il secondo gruppo monitora le celle successive.
L’idea sarebbe, un giorno, di collegare entrambe le batterie a un unico BMS, per poter così finalmente avere una batteria unica e poter quindi usare la frenata rigenerativa; dovrò però trovare il modo di installare comunque una batteria di emergenza, perchè se l’unica batteria si spegne/rompe, si spengono anche i fari! Il rischio non è ovviamente accettabile, quindi o metto una batteria di servizio da 12V, o una terza batteria da 60V…
La batteria finale ha BMS esterno, cosa che dovrebbe rendere più facile manutenzione, monitoraggio e upgrade.
20161109_175849.jpg

Diario elettrico Ecojumbo 5000 – 16 settembre 2016: batteria guasta

Posted in batterie, scooter elettrici by jumpjack on 24 settembre 2016

Una batteria mi ha improvvisamene piantato.

Il contakm segna 13900.

Nel viaggio di andata la batteria non ha dato nessun problema, ma a ritorno ho notato che il voltmetro scendeva parecchio in accelerazione, e una volta a casa ho verificato che staccando l’altra batteria lo scooter si spegneva.

La cosa strana, però, è che la batteria (da 60V) dà 65 volt! Però, se la collego allo scooter, questo non si accende; se la collego al caricabatteria, questo attacca e stacca continuamente a intervalli casuali, come se ci fosse un falso contatto.

Ho smontato e ispezionato la batteria, ma non vedo danni evidenti sul BMS; c’erano un paio di piazzole un po’ sporche di non so cosa, ma non sembrava un cortocircuito o un falso contatto, e anche dopo aver ripulito non è cambiato niente.

Ho quindi ordinato un po’ di materiale per la riparazione e, approfittando dell’occasione, per un upgrade:

BMS LiFePO4 60V

 

  • Connettori JST da 8, 10 e 12 pin:

 

  • JST XA da 12 pin per PCB:

 

  • JST  XA 12 pin per cavo:

Corpo connettore PCB JST serie XA, femmina, 12 vie, 1 fila, passo 2,5mm

 

  • Pin:

Contatto per connettore PCB JST femmina, a crimpare

 

  • JST EH 8 pin  per PCB:

Connettore circuito stampato JST 8 vie 1 file passo 2,5mm, 3A diritto serie EH

 

  • JST EH 8 pin per cavo:

Corpo connettore PCB JST serie EH, 8 vie, 1 fila, passo 2,5mm

 

  • JST EH 10 pin per PCB:

Connettore circuito stampato JST 10 vie 1 file passo 2,5mm, 3A diritto serie XH

 

  • JST XH 10 pin per PCB:

Connettore circuito stampato JST 10 vie 1 file passo 2,5mm, 3A diritto serie EH

 

 

Pin strip femmina da 20 pin:

Winslow 2.54mm 20 Way 1 Row Straight Through Hole Female PCB Socket Strip

Il progetto è questo:

Il BMS originale (marcato “PCM-L20S40-321 (B-1)” su un lato e “F-321-20S-60A-203” dall’altra) ha due connettori da 10 pin (oltre a un terzo da 8 pin che va a un circuito separato di gestione della potenza); quello nuovo ha un connettore da 12 e uno da 8 pin. Voglio costruire un adattatore che permetta di collegarli tra loro senza dover tagliare i fili del BMS originale (che potrei anche riuscire a riparare prima o poi…), e già che ci sono voglio aggiungergli un terzo adattatore, a cui collegare un CellLog8s.

ecoitalmotor-002 ecoitalmotor-003

 

La batteria: (Al centro, tra le due coppie di pacchi HC-13A8F5 , si vede l’insolito PCB lungo e stretto che gestisce la parte di potenza del BMS.)

ecoitalmotor-001

 

L’adattatore sarà ovviamente esterno, così come il nuovo BMS, il che faciliterà la manutenzione in caso di problemi futuri, ma soprattutto permetterà di monitorare costantemente le celle.

Studiando il log dei tentativi di carica con BMS guasto, poi, potrei restringere la ricerca alla sola linea – su 20 – che dà effettivamente problemi, esaminando poi più a fondo i singoli componenti in cerca di microfratture, corti, o quant’altro. Il problema principale è che il BMS è costituito da due PCB a castello saldati tra loro, e al momento non riesco a separarli, il che rende ovviamente impossibile esaminare l’intero BMS…

20160924_171156

 

Mentre aspetto che arrivino i pezzi, forse potrei rimettere in servizio una vecchia batteria LiCoO2 dello Zem, che da sola tira fuori ben poca corrente ormai, ma comunque potrebbe aiutare un po’ la povera batteria superstite.

Avevo totalmente dismesso, ma non buttato, le vecchie batterie, sia perchè ormai davano poca corrente, sia perchè si era rotto il miliardesimo caricabatterie e non mi andava di spendere 90 euro per un altro…

Però tempo fa ho comprato due caricabatterie LiFePO4 per sostituirne uno rotto e averne uno di scorta: potrei provare ad abbassarne il voltaggio da 73 a 67.2, come necessario per caricare le LiCoO2; dovrebbe bastare ruotare il potenziometro giusto nella direzione giusta della quantità giusta

 


Intanto, sto considerando anche la possibilità di aggiungere finalmente una ulteriore batteria agli umili 36 Ah che ho ora (adesso temporaneamente ridotti addirittura a 18), visto che ho molto spazio disponibile: o per un’altra batteria come queste, o per “qualcosa” che entri in uno spazio di 25x15x30 cm. Le celle Panasonic NCR18650 da 3000-35000 mAh, 250 WH/kg e 650 Wh/L sembrano invitanti (a parte i pochi cicli, 300-500), specie ora che costano intorno ai 400$/kWh, ma anche le nuovissime celle NCM (Nickel-Cobalto-Manganese) sembrano molto invitanti (sarebbero l’evoluzione non incendiaria delle LiPo)… se solo qualcuno le vendesse! Al momento conosco quest’unico sito (Shenzen Westart Technology ltd.), che non è attrezzato per e-commerce ma solo per contatti diretti con aziende (come dire: per pagare bisognerebbe versare “a fiducia” 1000-2000 euro su un IBAN ricevuto per e-mail…).

Queste celle sembrano avere la stratosferica durata di 3-4000 cicli, una densità di 150-170 Wh/kg e sicurezza paragonabile alle LiFePO4. Da notare però che sono da 3,7V anzichè 3,3, quindi richiedono elettronica diversa dalle LiFePO4.

Se usassi celle del tipo 18650 potrei riutilizzare così com’è, senza modifiche e accrocchi, i contenitori delle vecchie batterie dello Zem, che erano composte da 96 celle (16S6P) LiPo di marca ignota ma dimensioni 18650; quelle erano da 4000 mAh, mentre le Panasonic NCR 18650 sarebbero da 3000 o al massimo 3500 (ce ne sono vari tipi), quindi arriverei, invece che a 24Ah, a 18-21 Ah.

Quelle vecchie batterie avevano un volume di circa 8 litri, quindi a livello di batteria avevano una  densità di  1440 Wh/8L = 180 Wh/L.

Con 96  celle panasonic da 650 Wh/L otterrei, nello stesso spazio, una batteria da 1260 Wh, cioè 157 Wh/L  (possibile che da cella a batteria si passi da 650 a 157 Wh/L?!?)

 

 

 

 

 

 

Trovato nuovo sito europeo (Inghilterra) per batterie LiFePO4 e relativa elettronica (BMS, charger)

Posted in auto elettriche, batterie, scooter elettrici by jumpjack on 20 maggio 2014

Si chiama e-greenomotion:

http://e-greenmotion.com/index.php?route=product/product&product_id=68

Ha sia batterie A123 che Hedway (cilindriche), ma in compenso non ha le classiche prismatiche Winston, Sinopoly e Calb.

Però ha gli introvabili BMS da 60V… che poi ho scoperto invece essere effettivamente da 72V, quindi forse è per quello che mi risultavano introvabili! 🙂

Sono gli stessi di EclipseBikes, sempre inglese, ma qui sono personalizzabili, costano qualche euro in meno (92 invece di 98) e vengono spediti gratis!

Ma volendo hanno anche un BMS molto versatile che supporta da 8 a 32 celle in serie! Però ovviamente è caro: 280 euro!

 

 

 

Tagged with: , , ,

Batterie al litio in vendita in Europa

Posted in batterie, hardware, scooter elettrici by jumpjack on 24 novembre 2013

Ho finalmente trovato diversi siti europei che vendono celle al litio LiFePO4: in Polonia (.PL), Repubblica Ceca (.CZ), Germania (.DE),…

Per il momento mi sto soffermando su www.lipopower.de , perchè oltre alle batterie sembra avere un sacco di altra roba interessante: connettori intercelle,supporti per celle Headway e per celle A123, ma soprattutto questo interessante BMS da 16-24 celle: potrei usarlo infatti per fare esperimenti sia per una batteria provvisoria da 20 celle / 60Vper lo Zem Star 45, nel tentativo di farlo resistere fino a Maggio 2014, quando scadrà l’assicurazione, sia per l’Oxygen Lepton, che va a 48V e quindi richiede una batteria da 16 celle.

Penso che opterò per una prima batteriola di prova da 10-15 Ah, visto che per lo Zem non mi serve di più, e che è sufficiente per fare esperimenti con il Lepton, che assorbe 60-100A, mentre le celle sono da 10C, quindi 100-150A (anche se immagino che a 10C non durino molti cicli).

Esistono molti tagli di celle Headway:

  1. LiNANO ® 6 Ah 3.2V 20C Headway 38105SP (SL-FHW-38105P) – 21,20€, 65,1 Wh/kg, 19,20Wh, 143,5 Wh/L
  2. LiNANO® 8 Ah 3,2V 25C Headway 38120HP (SL-FHW-38120HP) – 21,85€, 76 Wh/kg, 25.6 Wh, 167 Wh/L
  3. LiNANO ® 8 Ah 3.2V 20C Headway 38120SP (SL-FHW-38120Pfuori produzione) – 18,50€, 76 Wh/kg, 25.6Wh, 167 Wh/L
  4. LiNANO® 9 Ah 3,2V 10C Headway 38120SE (SL-FHW-38120SE) – 16,50€, 86 Wh/kg, 28,8 Wh, 212 Wh/L
  5. LiNANO® 10 Ah 3,2V 10C Headway 38120SE (SL-FHW-38120SE) – 19,90€, 95,52 Wh/kg, 32 Wh, 209 Wh/L
  6. LiNANO® 11 Ah 3,2V 10C Headway 40120SE (SL-FHW-40120SE) – 23,75€, 97 Wh/kg, 38,4 Wh, 255 Wh/L
  7. LiNANO ® 12Ah 3.2V 10C Headway 38140SE (SL-FHW-38140SE) – 23,95€, 97 Wh/kg, 38,4 Wh, 220 Wh/L
  8. LiNANO ® 15 Ah 3.2V 10C Headway 40152SE (SL-FHW-40152SE) – 29,95€, 100 Wh/kg, 48 Wh

Sono disponibili anche in kit da 4 celle / 12V:

  1. LiNANO ® 8 Ah 12V HP25C (kit 4x) – 107,50€, 1,44 kg, 104 Wh
  2. LiNANO ® 8 Ah 12V SP20C (kit 4x) – 99,95€, 1,44 kg, 104 Wh
  3. LiNANO ® 9 Ah 12V 10C (kit 4x) – 79,95€, 1,44 kg, 115,2Wh
  4. LiNANO ® 12 Ah 12V 10C (kit 4x 38140SE) – 109,95€, 153,6 Wh,
  5. LiNANO® 14 Ah 12V 10C (kit 4x 38140SE ) – 109,95€ (errore?)
  6. LiNANO® 15 Ah 12V 10C (kit 4x 40152SE) – 133,75€

Invece, volendosi costruire la batteria da soli da zero:

  1. Supporto  per 20 celle da 38mm (SL-FHW-38120P, SL-FHW-38120S, SL-FHW-38140SE) – 7,50€ l’uno, ne servono 2
  2. Supporto da 38 mm per 3 celle – 0,85 euro l’uno, ne servono 2 ogni 3 celle, quindi 12 per 16 celle (13,6 €) e 14 per 20 celle (11,9 €)
  3. Supporto da 40 mm per 3 celle – 0,85 euro l’uno, ne servono 2 ogni 3 celle, quindi 12 per 16 celle (13,6 €) e 14 per 20 celle (11,9 €)
  1. Connettore in ferro per celle 38mm – 0,55€ – ne servono 34 per 16 celle (18,7€) e 42 per 20 celle (23,10€)
  2. Connettore in ferro per celle 40 mm –  0,55€ – ne servono 34 per 16 celle (18,7€) e 42 per 20 celle (23,10€)
  3. Connettore in rame per celle 38 mm – 0,90€ – ne servono 34 per 16 celle (30,6€) e 42 per 20 celle (37,80€)

BMS:

  1. BMS 16-24 celle con bilanciatore incorporato – 109,95€
  2. bilanciatore esterno per cella singola, corrente di bilanciamento  da 1400 mA – 4,75 euro – ne servirebbero 16 (76€) o 20 (95€); il vantaggio è che se ne brucio uno, non devo spendere altri 100 euro ma solo 5. Dovrei comprarne almeno 22, quindi diciamo 104,5€.

Varie:

  1. Connettore a 9 fili per bilanciatore – 2,75€ – ne servono 2 per 16 celle (5,50€) e 3 per 20 celle (8,25€)
  2. Guaina termorestringente – 12,05€/metro – non indispensabile, ma in genere si usa per ricoprire le batterie; ne potrebbero servire 2 metri – 24,10€
  3. Cavo rosso da 8 mm^2 – 5,95€/metro, ne basta 1 – 5,95€ (ottimo cavo con guaina in silicone morbido ultraflessibile e interno in fili di rame finissimi intrecciati)
  4. Cavo nero da 8 mm^2 – 5,95€  (ottimo cavo con guaina in silicone morbido ultraflessibile e interno in fili di rame finissimi intrecciati)
  5. Connettore Anderson da 50A – 6,95€ – ne esistono 3 tipi: rosso, blu e grigio, incompatibli tra loro; il mio Zem li monta grigi – ne prendo 4 –  27,8€

I prezzi complessivi risultanti (senza connettori Anderson):

  1. 48V/15Ah: 504,00 €, 7 kg
  2. 48V/40Ah: 1.486,00 €, 19 kg
  3. 60V/15Ah: 630,00 €, 9kg
  4. 60V/40Ah: 1.831,00 €, 24 kg

Spedizione: 35,00 euro

Diario elettrico Zem Star 45: prova batteria boost A123

Posted in batterie, scooter elettrici by jumpjack on 13 ottobre 2013

Dopo qualche mese di “sonno” ho ripreso in mano il progetto della batteria-boost basata su celle A123 ad alta potenza, scoprendo però quanto temevo: attualmente, così com’è, è totalmente inutile: siccome ci ho messo un BMS dotato di morsetti P,B e CH, vuol dire che deve essere ricaricata da un morsetto e usata da un altro… quindi è impossibile applicarla allo scooter in parallelo alle batterie esistenti: non si ricaricherebbe! E il mio scooter non ha la rigenerazione in frenata, quindi non potrei nemmeno ricaricarla separatamente.

Mi serve invece un BMS bidirezionale, facilmente (ora che lo so…) riconoscibile dall’assenza del connettore CH+, come questo:

http://shop.i-tecc.de/bms-pcb-pcm/bms-lifepo-16s-30a-48v.html

Viene dalla Germania, 82,50 euro, però è un po’ piccolo, da 30A; per una batteria che deve funzionare da sola non andrebbe bene, ma per una batteria di supporto dovrebbe andare, considerando che in teoria lo scooter assorbe 25A di picco, essendo da 1500W/60V (ma secondo me ha potenza di picco maggiore, boh. Purtroppo non esiste un datasheet del motore).

Il problema più grosso, però… è che questo è da 48V! A me serve da 60, roba rarissima; questo al massimo potrebbe andare bene per il Lepton…

Nel caso del Lepton, però, ci vorrebbe più potente, tipo questo da 60A:

http://shop.i-tecc.de/bms-pcb-pcm/bms-lifepo-16s-60a-48v.html

 

 

 

Tagged with: , , ,

Diario Elettrico – Restauro di Atala-Oxygen Lepton anni 2000 – 13 luglio 2013

Posted in auto elettriche, batterie, scooter elettrici by jumpjack on 13 luglio 2013

Uh oh…

winston-lepton-gonfie

Ho fatto una lunga prova di autonomia col Lepton e 16 celle Winston/THundersky LFP40AHA.

Sono riuscito a percorrere circa 15km prima che iniziasse a dare segni di cedimento in salita, ma in partenze in pianura era ancora piuttosto scattante. Poi però alla fine ha ceduto quando è successo quanto rappresentato nella foto…

Una cella era particolarmente calda, poi guardandola da vicino mi sono accorto che era anche un po’ gonfia, così ho deciso di tornare a casa, che per scelta era molto vicina: ho percorso 15 km senza mai allontanarmi più di un chilometro da casa, gira, che ti rigira, che ti rigira… 🙂

L’ultimo pezzo di strada era però una lunga discesa, che ho fatto “a manetta” per verificare una cosa… e ho verificato che col Lepton è impossibile superare i 50 km/h anche accelerando in discesa!

In compenso, quando ho lasciato l’acceleratore mentre andavo a 50 all’ora in discesa, è partito un regen da paura 🙂 che credo abbia “finito” la cella già danneggiata: dal motore hanno iniziato a venire rumoracci, il quadro si è spento, ma come al solito il motore è rimasto acceso, solo che appena acceleravo un po’, si spegneva, ma poi rilasciando l’acceleratore, l’aumento di tensione faceva riaccendere il quadro come un albero di natale, ma poi si rispegneva poco dopo… vabbè, un casino.

Arrivato a casa, ho verificato che non una  ma 2 celle “e mezzo” si sono danneggiate (per l’appunto erano adiacenti tutte e tre): quella “panciuta” a sinistra è arrivata a 0,04 volt (!!!) ed era bella calda, quella di mezzo ha raggiunto i 0,43 volt ed era tiepida, l’altra era sui 2,43 e non troppo gonfia, quindi forse era così già prima.

12 ore dopo, la cella panciuta è a zero volt, la seconda a 0,40 e la terza ancora a 2,43.

Ho anche fatto altre osservazioni sul riscaldamento: quei cavi che erano solo “appuntati” alle batterie, cioè con le viti non strette, erano tiepidini… mentre toccando i bulloni che li fissavano alle celle mi sono letteralmente ustionato! Quindi a un certo punto ho deciso di stringere bene tutte le viti… anche se domani dovrò riallentarle tutte per montare il BMS.

Sì, perchè tutto questo è successo perchè volevo vedere cosa succede a una batteria senza BMS.

Beh, ora lo so… e lo sapete tutti! 🙂

Non usate batterie al litio senza BMS!!!

Il BMS avrebbe “spento” la batteria leggendo una sottotensione su una cella; sarei tornato a casa a piedi, ma non avrei rovinato una cella.

Sul manuale d’uso della Winston c’è scritto però come fare per far tornare rettangolare una cella ingrassata, mi chiedo se quindi sia recuperabile, boh?!? Certo non è molto rassicurante averla tra i piedi, e neanche in casa, infatti stanotte ha “dormito” in giardino. 🙂

Altra cosa interessante è che il disco al centro delle celle è una valvola di sfogo di emergenza, che è ancora ben salda al suo posto; mi chiedo allora se il rigonfiamento sia dovuto a gas interni, o solo a deformazione degli elettrodi causata da sottotensione; non credo infatti che la sottotensione faccia sviluppare gas, solo la sovratensione dovrebbe farlo.

Solo che chissà che tensione vede una cella in mezzo ad altre 16 durante un regen a 50 all’ora?!? Sul Lepton non c’è nemmno uno straccio di voltmetro!

Comunque, cambiando discorso, nel frattempo ho trovato 5 supercondensatori in svendita a 200 euro totali, 16V/25F ciascuno, e ci sto ragionando un po’ su. 🙂 Su un Lepton si possono montare anche in serie alle batterie, perchè si ricaricherebbero col regen, e in questo modo preserverebbero  le batterie.

Solo che non capisco quanta corrente possono  sopportare questi supercap, sul datasheet non lo trovo scritto! Sono dei moduli con elettronica di controllo (datasheet) basati su SC BCAP0150 da 2,7V/150F della Maxwell. (Interessante il fatto che incorporino i circuiti di bilanciamento, un sacco di rogne in meno!)

Ognuno dovrebbe contenere 0,5 * 25 * 16^2 = 0,9 Wh , per un totale quindi di 4,5 Wh, che a 1500 W durerebbero 10 secondi se si potessero usare totalmente… cosa che non è vera: sullo Zem potrei usarli solo in parallelo alla batteria, quindi solo tra 60 e 64 V delle batterie scariche/cariche, quindi il vantaggio sarebbe minimo: 0,05 Wh l’uno, 0,3 Wh tutti, 0,7 secondi di autonomia!

Sul Lepton, invece, potrei metterli in seriealla batteria; però non in serie TRA LORO, perchè 48V+80V fa un po’ di più dei 70V sopportabili dalla centralina.. Dovrei allora fare un supercap in serie alla batteria, formato dai 5 SC in parallelo, ottenendo un supercap da 16V/125F.

Col SC alla massima carica, però, avrei 57,6+16=73V , che sono troppi…. Però è la centralina a caricare, e di certo non eroga 73V, ma forse 57,6 , o forse di più (di certo non di meno, secondo questa tabella. 

Questo vorrebbe forse dire che allora alla batteria arriverebbero al massimo 57,6-16 = 41,6 volt, perchè i 16 si “perderebbero” nel condensatore? Ma allora cosa impedisce al condensatore di ricevere PIU’ di 16 volt, cosa che lo distruggerebbe? L’elettronica di bordo lo bloccherebbe? Ma essendo in serie alle batterie, allora bloccherebbe completamente il regen…. ma chi se ne importa?

Certo non mi metto a comprare un DC/DC converter buck/boost da 1800W, costano un’esagerazione.

Insomma, come al solito, un miliardo di incognite, un sacco di documenti da studiare, cose da comprare, bruciare e poi buttare… 🙂

Aggiungo immagine con curve di scarica e intervalli di tensione evidenziati:

livelli-tensione-winston

AGGIORNAMENTO 1:

Sostituite le due celle, ho montato un BMS e messo in carica usando il CB di bordo dello scooter.
Ho notato che la tensione del CB a circuito aperto sale, sale, sale…. è arrivata fino a 60V mentre l’unica cosa che stava “caricando” era il tester, ma a quel punto l’ho spento perchè temevo che si trovasse in situazione non prevista e finisse per bruciarsi!
Invece una volta attaccato alle batterie ha iniziato a erogare 5 Ampere, terminando poi la carica a 51,8 volt totali.
La centralina/caricabatterie, che sul Lepton sono un tutt’uno, è diventata piuttosto calda durante la ricarica, ma è normale, secondo il manuale può arrivare anche a 60 gradi!
51,8 volt corrispondono a 12,95 volt a batteria nel caso del piombo;stando a questa immagine, per una batteria al piombo la tensione in stato di carica al 100% sarebbe di 13V (52V), che vengono raggiunti applicando alla batteria una tensione di 14,4-15V (57,6/60V).
Riportate su 16 celle, queste tensioni diventano:
100%: 3,25 V
Ricarica: 3,6-3,75 V
Stando al datasheet Thundersky, le celle non devono eccedere i 4,25 V, quindi siamo ampiamente entro i margini di sicurezza in fase di ricarica. Anche se secondo altre fonti la tensione massima deve essere 4,00 V, siamo comunque entro i margini di sicurezza.
Bisogna comunque tener presente che queste “LFP40AHA” hanno già subito tre evoluzioni negli anni, con annessi cambi di specifiche: nate come Thundersky, sono poi diventate Winston e attualmente sono Sinopoly, e nel tempo si sono anche arrichitte di Ittrio come stabilizzante, per cui esisteranno molteplici datasheet in giro…
Datasheet Winston: 2,5-4,25V
Datasheet Thundersky : 2,8-4,0V
Datasheet LYP40AHA
Datasheet Sinopoly: 2,8-3,8V
Da qualche parte ho letto che ricaricando una cella al litio tenendosi più bassi rispetto alla tensione massima possibile riduce lo Stato di Carica (SoC) di pochissimo (5-6%), ma prolunga notevolmente la vita delle batterie; però stranamente le Thundersky (Generazione 2) venivano date per 3000 cicli se scaricate all’80% partendo da 4,0V, mentre le Sinopoly (Gen. 3.0) vengono date per 2000 all’80% partendo da 3,8V. Solo che nelle Th2.0 c’era l’ittrio, mentre nelle Sinopoly 3.0 mi pare di no…
Tutto molto semplice, insomma

 

AGGIORNAMENTO 2:
Dopo aver caricato l’altroieri le batterie fino a 51,8 volt tramite BMS e caricabatterie di bordo, le ho lasciate sullo scooter, collegate, ovviamente a scooter spento.
Oggi, 36 ore dopo, 13 celle su 16 hanno tensione tra 0,002 e 0,50 volt! Solo le 3 che erano a 3,8 ora sono a 3,3!
Come si spiega?!?

Io speravo che, collegate al BMS ma non in uso da parte dello scooter, le celle sarebbero state bilanciate dal BMS… invece col fischio!
Adesso ho non una ma una decina di celle gonfie come palloncini! Talmente gonfie che neanche riesco più a sfilarle dallo scooter….
Ho controllato i collegamenti: avevo CH- scollegato, P- scollegato, B- collegato al negativo della batteria, e lo scooter collegato direttamente alla batteria… ops… forse è questo il problema? Dovevo invece collegarlo all’uscita P- del BMS invece che B-?
Mi viene in mente che anche con le batterie al piombo lo scooter mi ha fatto uno scherzo del genere, ma pensavo fosse colpa delle batterie vecchie ed esauste: 3 giorni dopo averle caricate, senza usare lo scooter le ho trovate a tensioni tra 5 e 7 volt (batterie da 12 volt!)

Se a questo si aggiunge lo strano fatto che, una volta che ho acceso lo scooter, è impossibile spegnerlo e l’acceleratore fa girare il motore anche a chiave disinserita (!), viene da pensare che lo scooter anche da “apparentemente spento” abbia un bel consumo di corrente, che “spiana” le batterie.

Certo, se avessi collegato lo scooter a P- invece che a B-, magari il BMS avrebbe spento tutto evitando la sottoscarica… forse… che ne so?
Fatto sta che la batteria era arrivata a 18 volt complessivi!
Dopo qualche minuto di ricarica, è successo qualcosa di strano: le celle si sono come riattivate, passando da 0,5 volt a 2,6-2,7 (tranne una che rimane a 0,0012, ma che non è nemmeno la più gonfia di tutte), e la batterie nell’insieme è arrivata a 41 volt. Un paio di celle rimangono su 1,5-1,6 volt.
Il problema è che la batteria è rimasta inchiodata a 41 volt per un’ora!
Allora ho provato a staccarla dal CB e misurare la tensione del CB, scoprendo che forse ha 3 modalità:
– tensione fissa a 41 volt (mantenimento batterie?)
– ricerca: la tensione sale gradualmente da 40 a 62 volt se non c’è batteria attaccata, dopodichè torna su 41 e lì si blocca; entra in questa modalità se spengo e riaccendo il CB a batteria scollegata
– ricarica: se mentre il CB è in ricerca connetto la batteria, inizia la ricarica

Succede “qualcosa” anche alla spia a forma di spina di corrente sul cruscotto: a quanto pare lampeggia, sta fissa o sta spenta a seconda di… che ne so, non l’ho capito! 🙂 Chissà se è scritto sul manuale.
Meno male che domani mi arriva il CB esterno, questo mi ha stufato!
Poi, alla luce delle <a href=”https://jumpjack.wordpress.com/2013/07/14/quanto-e-utile-la-rigenerazione-di-energia-in-frenata-sui-mezzi-elettrici/”mie recenti scoperte sulla pressochè totale inutilità del regen su uno scooter da 80kg</a>, metto un bel diodo e festa finita! (paradossalmente, il regen era più utile quando c’erano 40 kg in più di batterie)

Batteria boost a123 – primi test

Posted in batterie, scooter elettrici by jumpjack on 24 maggio 2013

Finalmente è l’ora del test su strada!

Accroccato lo scrondo sul porta-bauletto, faccio i vari collegamenti e mi accingo a partire… ma qualcosa non va.

Primo test:

Batteria Lepton a 49.2 V

Batteria boost a 52.6

Collego “B-” alla massa dello scooter, “B16/B+” al positivo dello scooter (ma con le batterie al piombo staccate), accendo lo scooter, accelero… la ruota inizia a girare. OK, sembra funzionare.

Però, appena provo ad accelerare… inizio a sentire puzza di bruciato! Il BMS fuma!!! Porco cane, stacco tutto!!!

Ma che è successo?!? Ricontrollo i collegamenti… aspetta un po’, mi sa che non devo collegare B- alla massa dello scooter, ma P- (Power, cioè l’uscita del BMS). Non capisco come collegare B- (ingresso al BMS, proveniente dalla batteria al litio) al negativo della batteria al piombo col positivo scollegato possa aver bruciato qualcosa, boh?!? CH- invece (ingresso di ricarica del BMS) neanche l’ho usato, perchè l’unico modo sarebbe collegarlo alla massa dello scooter, visto che dovrebbe essere la batteria dello scooter a ricaricare la batteria boost, quindi nel dubbio per ora l’avevo lasciato scollegato.

Secondo test:

Visto che, dopo la fumata, tra P- e P+  ci sono comunque ancora 52 volt, faccio il collegamento “giusto” (?), cioè P- alla massa dello scooter e P+ al positivo, e provo a ripartire: lo scooter fa cinque centimetri e poi si spegne tutto con un’altra fumata del BMS seguita da un piccolo scoppietto! E stavolta tra P- e P+ compaiono due soli volt… Mi sono giocato il BMS! (a vedersi sembra scoppiata una resistenza, ma boh…)

Terzo test:

va bene, il BMS è andato, ma una prova devo riuscire a farla lo stesso, tanto una sola “scaricata” alle batterie senza bilanciamento non può danneggiarle, e visto che sopportano 60A continui e 120 per 10 secondi, non dovrebbero esserci problemi a fare un po’ di brevi prove. Quindi bypasso il BMS, e collego al negativo dello scooter non P- ma B-; così mi accorgo che il B- della batteria al litio NON era collegato al B- del BMS, ma rimasto volante…. ???? Possibile allora che questo abbia fatto bruciare il BMS? Continuo a non capire.

Comunque, almeno adesso, con le batterie connesse direttamente, lo scooter funziona: riesco a partire, a fare una decina di metri, poi comincia la salità del 15-20%: riesco a salire… ma stranamente vado PIU’ PIANO che con le batterie al piombo (al momento ancora scollegate). Ma come?!? E ‘sti 60/120A dove cavolo sono?!? Per di più, non riesco nemmeno ad arrivare in cima alla salita (lunga forse 100 metri), lo scooter si ferma! Devo attaccare le batterie al piombo per arrivare in cima e poter continuare i test!

Quarto test:

Adesso collego sia le batterie al piombo che la boost al litio, e faccio diverse volte il salitone; ogni volta, quando arrivo in cima, i cavi “leggeri” della batteria al piombo non sono caldi: SCOTTANO! Se la salita durasse un minuto invece che 20 secondi, probabilmente la guaina si scioglierebbe, o peggio si incendierebbe!!! Nessun problema invece sui cavi originali, al massimo sono tiepidi quelli più sottili.

Problemi (previsti) invece, sulla batteria al litio: per bypassare la cella che non sono riuscito a saldare, in mancanza di cavo adatto avevo dovuto usarne uno più sottile degli altri, e quindi è diventato tiepido, ma comunque molto meno caldo di quello delle batterie al piombo. Ma come MENO? Non doveva venire per lo più dalla batteria boost la corrente?!?

Ma non è tutto: dopo mezz’ora di prove, non sono solo i fili a essere caldi: tutte le celle sono molto calde! Non scottano, ma sono palesemente calde, e questo non va bene per niente: si sono scaldate dopo tre salite?!? E dopo un’ora di viaggio in scooter cosa farebbero, si squaglierebbero?!?

Al termine dei test, la batteria boost dà 46.6 volt, cioè in teoria 2,91V a cella…. ma stupidamente ho dimenticato di misurare le singole celle per sapere se il BMS, a parte non avere più il circuito di potenza, riesce almeno a bilanciare! Me ne ricordo solo 3 ore dopo: quasi tutte le celle sono tra 2,91 e 2,94V, tranne 2 che sono una a 3,00 e una 2,50. Ma quel che è peggio è che la cella n.1 è a 0,10V (zero virgola 10???). Come fa una cella al litio ad arrivare a 0,10V?!? Senza scoppiare o incendiarsi, per giunta?!?

Non ci siamo proprio, questi primi test sono davvero deludenti e preoccupanti!

Però anche il mio accrocco è deludente, con saldature approssimative, cavi inadatti, e BMS fritto.

Ho ordinato una speciale pasta per saldare l’alluminio, per cercare di saldare l’ultima cella: quando arriva, se funziona risaldo per bene tutte le celle, e potrò fare i test col BMS da 60V, e vedere un po’ cosa succede.

Intanto, per adesso ho imparato questo sui BMS:

  • P-/P+: contatti di Potenza in uscita dal BMS; ma in realtà P+ non c’è sul BMS, è il polo positivo della batteria a fungere da P+ (oltr eche da B+, vedi sotto).
  • B-/B+: contatti di ingresso al BMS, provenienti dalla batteria; ma in realtà B+ non esiste, perchè B+ e P+ vanno insieme.
  • CH-/CH+: contatti di ricarica della batteria; anche qui, il positivo non esiste sul BMS, perchè è in comune con B+ e P+. In pratica, CH+, B+ e P+ sono tutti la stessa cosa, e cioè il polo positivo della batteria, ossia dell’ultima cella, quindi il contatto B16 della serie. Invece, B- sarebbe il contatto Bzero, cioè il negativo della prima cella, mentre B1 è il positivo della prima cella.

Non mi è ben chiaro se e come posso usare CH- nella mia configurazione con batteria che deve sia scaricarsi sullo scooter che ricaricarsi tramite lo scooter, anzichè ricaricarsi tramite caricabatterie esterno.

La cosa bizzarra è che nel BMS da 48V il B- non è presente tra i fili di bilanciamento, quindi il negativo della batteria va collegato al BMS separatamente, mentre in quello da 60V il B- è il primo contatto del morsetto.

Gli schemi di cablaggio dei due BMS:

48VBMS60A-150A

60VBMSAGGIORNAMENTO:

QUeso è come credevo che dovesse essere un circuito con batteria boost:

Diapositiva1

Questo è quello che pensavo dopo aver letto gli schermi di cablaggio dei miei BMS:

Diapositiva2

Questo è invece quello che penso dovrebbe essere in realtà, dopo una lettura più approfondita:

Diapositiva3

Evidentemente il controllo sulla corrente erogata viene effettuato sul “canale negativo” del collegamento, visto che sul BMS non c’è nessun morsetto positivo.

Per quanto riguarda il morsetto CH- di ricarica… boh? 🙂 Che ci faccio? Se lo collego al “-” della batteria al piombo, vuol dire che lo metto in corto con P-, non lo so mica se si può fare!!

Detto questo, ecco i “veri nomi” dei due BMS, scritti sui PCB, molto ben nascosti nel “sandwich” (sono 3 PCB sovrapposti per ogni ):

60V: PCM-L24S60-622(A)

48V: PCM-L16S70-563(B)

Tagged with: , , , ,